


<!DOCTYPE html>
<html xmlns:fb="http://www.facebook.com/2008/fbml" xmlns:og="http://opengraph.org/schema/">
<head>
  <meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
  <meta http-equiv="Content-Language" content="en-AU">
  <meta name="abstract" content="The Newspaper for the IT Channel.">
  <meta name="description" content="Oracle says yes and Google says no, but who’s right? Here are seven arguments in favour of copyrighting APIs - and seven arguments against">
  <meta name="keywords" content="copyright, Oracle, Google, API">
  <meta name="copyright" content="&copy; 2020 IDG Communications">
  <meta name="resource-type" content="document">
  <meta name="date" content="Wednesday, 8th April 2020">
  <meta name="robots" content="index,follow, noarchive">
  <meta name="viewport" content="width=device-width, initial-scale=1.0, user-scalable=no, minimum-scale=1.0, maximum-scale=1.0">
  <link rel="shortcut icon" href="https://www.idgcdn.com.au/compressor-staticfiles/arn/images/favicon.ico?release=20200406163827">
  <title>Can APIs be copyrighted? - ARN</title>

  <!--[if lt IE 9]>
  <script src="//html5shim.googlecode.com/svn/trunk/html5.js"></script>
  <![endif]-->

  <script type="text/javascript" src="https://ajax.googleapis.com/ajax/libs/jquery/1.8.3/jquery.min.js"></script>
  <link href="https://www.idgcdn.com.au/compressor-staticfiles/arn/arn.css?release=20200406163827" rel="stylesheet" type="text/css" />
  <link rel="stylesheet" type="text/css" href="https://www.idgcdn.com.au/compressor-staticfiles/jobs/jobbox.css?release=20200406163827" media="screen,print" />
  <link rel="stylesheet" type="text/css" href="https://www.idgcdn.com.au/compressor-staticfiles/brand_posts/style.css?release=20200406163827" media="screen,print" />
    

<script type = "text/javascript">                                                     
window._sp_ = window._sp_ || {};
window._sp_.config = window._sp_.config || {};

//by Sourcepoint
window._sp_.config.account_id = 146;

// replace 'mms.sp-prod.net' with your CNAME.d messaging subdomain
window._sp_.config.mms_domain = 'cmp.arnnet.com.au' ;

// messaging-specific configuration
window._sp_.mms = window._sp_.mms || {};
window._sp_.mms.cmd = window._sp_.mms.cmd || [];

//CMP Flags
window._sp_.config.cmp = _sp_.config.cmp || {};
window._sp_.config.cmp.enabled = true;
window._sp_.config.cmp.waitForConsentData = true;

//Code to call the server and display a message
window._sp_.mms.cmd.push( function () {
    window._sp_.mms.startMsg();
});
</script>

<script type="text/javascript" src="//demo.idg.com.au/staticfiles/cmp/messaging.js"></script>

<script>
var consent = consent || {};
consent.isEU = consent.isEU || null;
consent.personalization = consent.personalization || null;
consent.ads = consent.ads || {};
consent.ads.queue = consent.ads.queue || [];

consent.infostorage = consent.infostorage || {};
consent.infostorage.queue = consent.infostorage.queue || [];

consent.adsel = consent.adsel || {};
consent.adsel.queue = consent.adsel.queue || [];

consent.contentsel = consent.contentsel || {};
consent.contentsel.queue = consent.contentsel.queue || [];

consent.socmedia = consent.socmedia || {};
consent.socmedia.queue = consent.socmedia.queue || [];

consent.tealium = consent.tealium || {};
consent.tealium.queue = consent.tealium.queue || [];

consent.digitalelement = consent.digitalelement || {};
consent.digitalelement.queue = consent.digitalelement.queue || [];

consent.purposes = consent.purposes || {};
consent.purposes.standard = consent.purposes.standard || [];
consent.purposes.custom = consent.purposes.custom || [];
consent.vendors = consent.vendors || {};
consent.vendors.standard = consent.vendors.standard || [];
consent.vendors.custom = consent.vendors.custom || [];
</script>

<script>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</script> 

  <script async src="//js-sec.indexww.com/ht/p/183980-58731137839488.js"></script>

  
<meta property="fb:app_id" content="105374282841262" />
<meta property="og:site_name" content="ARN" />


  <!-- Facebook Pixel Code -->
<script>
!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
document,'script','https://connect.facebook.net/en_US/fbevents.js');

fbq('init', '1724434721147660');
fbq('track', "PageView");</script>
<noscript><img height="1" width="1" style="display:none"
src="https://www.facebook.com/tr?id=1724434721147660&ev=PageView&noscript=1"
/></noscript>
<!-- End Facebook Pixel Code -->

  



<script src="https://www.idgcdn.com.au/compressor-staticfiles/permutive/adsbygoogle.js?release=20200406163827"></script>
<script>

  var adblockerOn;
  if( typeof canRunAds != "undefined" && canRunAds ){
    adblockerOn = false;
  }else{
    adblockerOn = true;
  }

  function getMetaDescription(){
    var metas = document.querySelectorAll('meta')
    for(var i=0;i<metas.length;i++){
        if(metas[i].getAttribute('name')==='description'){
          return (metas[i].getAttribute('content'));
        }
    }
    return ''
  }

  function getMetaKeywords(){
    var metas = document.querySelectorAll('meta')
    for(var i=0;i<metas.length;i++){
        if(metas[i].getAttribute('name')==='keywords'){
          var newStr = (metas[i].getAttribute('content'));
          return newStr.split(',');
        }
    }
    return []
  }

  !function(n,e,o,r,i){if(!e){e=e||{},window.permutive=e,e.q=[],e.config=i||{},e.config.projectId=o,e.config.apiKey=r,e.config.environment=e.config.environment||"production";for(var t=["addon","identify","track","trigger","query","segment","segments","ready","on","once","user","consent"],c=0;c<t.length;c++){var f=t[c];e[f]=function(n){return function(){var o=Array.prototype.slice.call(arguments,0);e.q.push({functionName:n,arguments:o})}}(f)}}}(document,window.permutive,"f5b3be27-f789-4ef1-8867-37c67da5b361","84c7e805-5ce9-41f4-b988-3529488bab1c",{});
  permutive.addon('web', {
    page: {
      type: "article",
      keywords: getMetaKeywords(),
      language: "en",
      tags: ['copyright', 'Oracle', 'Google', 'API'],
      audience: "channel",
      description: getMetaDescription(),
      article: {
        authors: "Peter Wayner" === "None"?null:["Peter Wayner"],
        description: "Oracle says yes and Google says no, but who’s right? Here are seven arguments in favour of copyrighting APIs - and seven arguments against." === "None"?null:"Oracle says yes and Google says no, but who’s right? Here are seven arguments in favour of copyrighting APIs - and seven arguments against.",
        id: "672109" === "None"?null:"672109",
        isInsiderContent: false,
        modifiedAt: "2020-03-23T21:01:16Z" === "None"?null:"2020-03-23T21:01:16Z",
        publishedAt: "2020-03-24T04:00:00Z" === "None"?null:"2020-03-24T04:00:00Z",
        source: "ARN",
        title: "Can APIs be copyrighted?",
        type: "Article" === "None"?null:"Article",
        purchaseIntent: "None" === "None"?null:"None"
      },
      ads: {
        adblocker: adblockerOn,
        enabled: true
      },
      gTax: {
        primaryIds: [],
        secondaryIds: []
      },
      tax: {
        primaryCategories: [],
        secondaryCategories: []
      }
    }
  });

window.permutive.track('User', {
  companySize: "None" === "None"?null:"None",
  country: "None" === "None"?null:"None",
  id: "None" === "None"?null:"None",
  jobIndustry: "None" === "None"?null:"None",
  jobPosition: "None" === "None"?null:"None",
  purchaseIntent: "None" === "None"?null:"None",
  loggedIn: false,
})

</script>
<script async src="https://cdn.permutive.com/f5b3be27-f789-4ef1-8867-37c67da5b361-web.js"></script>



  



<meta property="og:title" content="Can APIs be copyrighted?" />
<meta property="og:type" content="article" />
<meta property="og:image" content="https://d2bs8hqp6qvsw6.cloudfront.net/article/images/800x800/dimg/dreamstime_s_142499163.jpg" />
<meta property="og:url" content="https://www.arnnet.com.au/article/672109/can-apis-copyrighted/" />
<meta property="og:description" content="Oracle says yes and Google says no, but who’s right? Here are seven arguments in favour of copyrighting APIs - and seven arguments against." />

<!-- The below is the code for twitter cards for all the article pages -->






<meta name="news_keywords" content="copyright, Oracle, Google, API">



<link rel="canonical" href="https://www.infoworld.com/article/3532896/can-apis-be-copyrighted.html" />


<link href="https://www.idgcdn.com.au/compressor-staticfiles/article/magnific-popup.css?release=20200406163827" media="all" rel="stylesheet" type="text/css">
<link href="https://www.idgcdn.com.au/compressor-staticfiles/article/article.css?release=20200406163827" media="all" rel="stylesheet" type="text/css">
<link href="https://www.idgcdn.com.au/compressor-staticfiles/article/comment.css?release=20200406163827" media="all" rel="stylesheet" type="text/css">
<link href="https://www.idgcdn.com.au/compressor-staticfiles/article/social.css?release=20200406163827" media="all" rel="stylesheet" type="text/css">

<link rel="alternate" type="application/rss+xml" title="ARN: copyright" href="/rss/tag/copyright/" />

<link rel="alternate" type="application/rss+xml" title="ARN: Oracle" href="/rss/tag/oracle/" />

<link rel="alternate" type="application/rss+xml" title="ARN: Google" href="/rss/tag/google/" />

<link rel="alternate" type="application/rss+xml" title="ARN: API" href="/rss/tag/api/" />

<link rel="alternate" type="application/rss+xml" title="ARN: by Peter Wayner" href="/rss/author/1950359870/peter-wayner/" />





<link href="https://www.idgcdn.com.au/compressor-staticfiles/social_login_sass.css?release=20200406163827" rel="stylesheet" type="text/css" />

<link href="https://www.idgcdn.com.au/compressor-staticfiles/article/magnific-popup.css?release=20200406163827" media="all" rel="stylesheet" type="text/css">
<link rel="stylesheet" type="text/css" href="https://www.idgcdn.com.au/compressor-staticfiles/article/article_infinite.css?release=20200406163827" />

<link rel="stylesheet" type="text/css" href="https://www.idgcdn.com.au/compressor-staticfiles/arn/style.css?release=20200406163827" />
<link rel="stylesheet" type="text/css" media="all" href="https://www.idgcdn.com.au/compressor-staticfiles/polls/polls.css?release=20200406163827" />

</head>
<body class="arn lo-responsive  twocolumns_noLHS">

<header id="lo-header" class="lo-header" role="banner">
  <div class="lo-header_top">
    <div class="logo-warp">
      
      <a href="/" id="lo-logo" class="lo-logo">ARN - Australian Reseller News</a>
      
    </div>
    
    <div class="lo-leaderboard">
<div class="gpt-ad" id="gpt-ad-top-banner-2068735" data-gpt-ad-unit-path="/8456/IDG.AU_B2B_ARNnet.com.au/software_section" data-gpt-sizes="[[728, 90]]" data-gpt-targeting='{&quot;node&quot;: [&quot;672109&quot;], &quot;idgau_tax&quot;: [&quot;news&quot;], &quot;site&quot;: [&quot;arn&quot;], &quot;sect&quot;: [&quot;software&quot;], &quot;idgau_search_referrer&quot;: [&quot;no&quot;], &quot;type&quot;: [&quot;article&quot;]}' data-gpt-size-mapping="[[[728, 90], [[728, 90]]], [[0, 0], []]]">
</div>
<div class="house-slot" style="display:none" data-name="" data-min-width="">

</div>

</div>
    

    <div class="lo-nav_button" id="lo-nav_button"></div>
  </div>
  <nav class="lo-nav" id="lo-nav">
    <ul>
      <li class="search">
        <form action="/search/" method="get">
          <input type="search" placeholder="Search" name="q" class="text">
          <input type="submit" name="op" value="Submit">
        </form>
      </li>
      <li class="super">
        <a href="/tax/news">News</a>
        <div class="lo-nav_sub news">
          <div class="inner">
            <div class="lo-nav_submenu">
              <ul class="sections">
                <li><a href="/tax/news" class="all">All News</a></li>
                <li><a href="/section/government/">Government</a></li>
                <li><a href="/section/products/">Products</a></li>
                <li><a href="/tax/round_table/">Round Table</a></li>
                <li><a href="/section/yarn/">yARN</a></li>
                <li><a href="/section/5_for_15/">5 for 15</a></li>
              </ul>
            </div>
            <div class="placeholder" data-placeholder="sub_news_latest"></div>
          </div>
        </div>
      </li>
      <li class="super">
        <a href="#">Tech</a>
        <div class="lo-nav_sub tech">
          <div class="inner">
            <div class="main lo-nav_submenu">
              <h2>Technologies</h2>
              <ul>
                <li><a href="/section/3d_printing/">3D Printing</a></li>
                <li><a href="/section/apps/">Apps</a></li>
                <li><a href="/section/cloud_computing/">Cloud Computing</a></li>
                <li><a href="/section/data_centre/">Datacentre</a></li>
                <li><a href="/section/mobility_and_wireless/">Mobile Solutions</a></li>
              </ul>
              <ul>
                <li><a href="/section/msp/">MSP</a></li>
                <li><a href="/section/networking/">Networking</a></li>
                <li><a href="/section/pc_and_components/">PC and Components</a></li>
                <li><a href="/section/products">Products/Reviews</a></li>
                <li><a href="/section/security/">Security</a></li>
              </ul>
              <ul>
                <li><a href="/section/social_networking/">Social Networking</a></li>
                <li><a href="/section/storage/">Storage</a></li>
                <li><a href="/section/software/">Software</a></li>
                <li><a href="/section/tech_hive/">Tech Hive</a></li>
                <li><a href="/section/telecommunications/">Telecommunications</a></li>
              </ul>
              <ul>
                <li><a href="/section/unified_communications/">Unified Communications</a></li>
                <li><a href="/section/virtualisation/">Virtualisation</a></li>
                <li><a href="/section/windows_8_central/">Windows 8 Central</a></li>
              </ul>
            </div>
            <div class="markets lo-nav_submenu">
              <h2>Markets</h2>
              <ul>  
                <li><a href="/section/green_channel/">Green Channel</a></li>
                <li><a href="/section/continuing_coverage/market_watch/">Market Watch</a></li>
                <li><a href="/section/retail/">Retail</a></li>
                <li><a href="/section/integration_and_services/">Services</a></li>
                <li><a href="/section/smb_market/">SMB Market</a></li>
              </ul>
            </div>
          </div>
        </div>
      </li>
      <li class="super">
        <a href="/events/upcoming/">Events</a>
        <div class="lo-nav_sub events">
          <div class="inner">
            <div class="placeholder" data-placeholder="sub_events_hotevents"></div>
            <div class="placeholder" data-placeholder="sub_events_latest"></div>
            <a class="lo-nav_more" href="/events/upcoming/">View all events</a>
          </div>
        </div>
      </li>
      <li class="super">
        <a href="#">Resources</a>
        <div class="lo-nav_sub resources">
          <div class="inner">
            <h2>Resources</h2>
            <div class="main lo-nav_submenu">
              <ul>
                <li><a href="/section/featured_whitepapers">ARN Library</a></li>
                <li><a href="/microsites">Microsites</a></li>
                <li><a href="/webinar/">Webinars</a></li>
                <li><a href="/video/">Videos</a></li>
                <li><a href="/contacts">Contacts</a></li>
              </ul>
              <ul>
                <li><a href="/brand-post/">Brand Posts</a></li>
                <li><a href="/digital_edition/all/">e-Mags</a></li>
                <li><a href="mailto:leon_spencer@idg.com.au">Email the Editor</a></li>
                <!-- <li><a href="/jobs/">Jobs</a></li> -->
                <li><a href="/mediareleases/">Media Releases</a></li>
              </ul>
              <ul>
                <li><a href="/slideshow/">Slideshows</a></li>
                <!-- <li><a href="/user/magazines/">Subscribe to print</a></li> -->
                <li><a href="/user/mailing_list">Subscribe online</a></li>
                <!-- <li><a href="https://subscriptions.idg.com.au/">Subscribe to IDG Publications</a></li> -->
                <li><a href="http://www.idg.com.au/specifications/">Ad Specifications</a></li>
              </ul>
            </div>
          </div>
        </div>
      </li>
      <li class="super">
        <a href="#">Directories</a>
        <div class="lo-nav_sub directories">
          <div class="inner">
            
            <form class="distributor" action="/distributor_directory/search" method="get">
              <h2><a href="/distributor_directory">Distributor Directory</a></h2>

              <div class="lo-nav_dir_inputs distributor">
                <input placeholder="Search for Distributor" type="text" name="q" size="35">
                <input type="submit" value="Search">

                <div class="browse">
                  Find distributors by <a class="dist" href="/distributor_directory/by_name">name</a> | 
                  <a class="dist" href="/distributor_directory/vendors">vendor</a> | 
                  <a class="dist" href="/distributor_directory/office_location">location</a>
                </div>
              </div>
            </form>
            <form class="vendor" action="/vendor_directory/search/" method="get">
              <h2><a href="/vendor_directory">Vendor Directory</a></h2>
              <div class="lo-nav_dir_inputs vendor">
                <input placeholder="Search for Vendor" type="text" name="q">
                <input type="submit" name="op" value="SEARCH">

                <div class="browse">
                  Find vendors by <a class="dist" href="http://www.arnnet.com.au/vendor_directory/by_name/">name</a> |
                  <a class="dist" href="http://www.arnnet.com.au/vendor_directory/">category</a> 
                </div>
              </div>
            </form>
          </div>
        </div>
      </li>
      <li class="super nav-tab-small-screen">
        <a href="#">More</a>
        <div class="lo-nav_sub resources">
          <div class="inner">
            <h2>More</h2>
            <div class="main lo-nav_submenu">
              <ul>
                <li><a href="/contacts/">Contact</a></li>
                <li><a href="/award_winners/arn-ict-industry-awards-2019/2019/">Platinum Club</a></li>
              </ul>
            </div>
          </div>
        </div>
      </li>
      <li class="nav-tab-large-screen">
        <a href="/contacts/">Contact</a>
      </li>
      <li class="nav-tab-large-screen">
        <a href="/award_winners/arn-ict-industry-awards-2019/2019/">Platinum Club</a>
      </li>
     <!-- <li>
        <a href="/channel_influencers/">Channel Influencers</a>
      </li>-->
      <li class="user super">
        
          <a href="#">Sign in/Subscribe</a>
        
        <div class="lo-nav_sub user">
          <div class="inner">
            
            <section class="existing">
              <h2>Existing Member</h2>
              <form action="/user/login/" accept-charset="UTF-8" method="get"><input type='hidden' name='csrfmiddlewaretoken' value='t5Mw6kieYN0UOoa7NEzidJOGiwJWa18ak47GjqIwA5kffEz25YHl3vfP2pNvjqb4' />
                <input type="submit" name="op" value="Log in">
                <p class="forgot"><a href="/user/password/">Forgot password?</a></p>
              </form>
            </section>
            <section class="join">
              <h2>Join ARN</h2>
              <p>Sign up to gain exclusive access to email subscriptions, event invitations, competitions, giveaways, and much more.</p>
              <a href="/user/register/?location=top_nav_bar">Sign up now</a>
            </section>
            
          </div>
        </div>
      </li>
    </ul>
  </nav>
</header>

<div id="skin">
<div id="headerpromos"></div>
<div id="otp_target"></div>
<div id="noskin_bump" class="lo-skin_bump"></div>


<div id="main" class="lo-content skin_wrap">
<div class="lo-columns " id="site_columns">

  
    
    
    
      

<script>
	var link = document.createElement( "link" );
	link.href = "https://www.idgcdn.com.au/compressor-staticfiles/hotbar/hotbar.css?release=20200406163827";
	link.type = "text/css";
	link.rel = "stylesheet";

	document.getElementsByTagName( "head" )[0].appendChild( link );
</script>

<div class="evt-countdown" style="height: 50px; ">
	<img class="evt-countdown_background" src="/dimg/-1x-1/hotbar/1080x50_6.png">
	<p class="evt-countdown_text">
		
	</p>
	<a class="evt-countdown_link" href="https://www.arnnet.com.au/emerging_leaders/"></a>
</div>

    
    
  

  

  
  <div class="lo-column lo-main   " id="site_columns_main">
    
<div id="art-articles_wrap" class="art-articles_wrap art-articles_wrap_infinite">

  <div class="art-topbar" id="art-topbar">
    <div class="art-topbar_content">
      <a id="art-topbar_menu_button_arn" class="art-topbar_menu_button" href="#">Menu</a>

      <a class="art-topbar_logo" href="/">ARN</a>
      <div class="art-progress" id="art-progress">
        <div class="art-topbar_currect" id="art-topbar_currect">
          Can APIs be copyrighted?
        </div>
        <div class="art-next" id="art-next">
          <a class="art-nextlink" id="art-nextlink" href="#"></a>
        </div>
      </div>
    </div>
    <div class="art-progress_bar" id="art-progress_bar"></div>
  </div>

  <div id="art-next_signifier" class="art-next_signifier">
    <div class="art-next_signifier_content">
      <span class="art-next_signifier_image" id="art-next_signifier_image"></span>
      <h3 class="art-next_signifier_title" id="art-next_signifier_title"></h3>
    </div>
  </div>


  

  <div itemscope itemtype="http://schema.org/Article" class="art-wrap article_wrap" id="article_wrap_672109" data-article-id="672109" data-article-headline="Can APIs be copyrighted?" data-article-url="/article/672109/can-apis-copyrighted/">

    <meta itemprop="sourceOrganization" content="InfoWorld" />
    <article class="art-article full">

      <header class="art-header">
        <h1 itemprop="name" class="art-title">Can APIs be copyrighted?</h1>
        <p class="art-sms sms">Oracle says yes and Google says no, but who’s right? Here are seven arguments in favour of copyrighting APIs - and seven arguments against</p>

        
        

        
        



<div class="art-social article_social" id="article_social_0" data-article-id="672109" data-article-url="https://www.arnnet.com.au/article/672109/can-apis-copyrighted/">
	<div class="art-byline art-byline_withpic">

		
			<a class="art-author_pic" href="/author/1950359870/peter-wayner/articles">
			
				<img src="https://d2bs8hqp6qvsw6.cloudfront.net/author/100x100/authors/1280px-idg_logosvg_6.png" alt="Peter Wayner">
			
			</a>
		

		<span class="art-author">
		
      <!-- Condition to display the Channel Asia instead of Channel Asia Singapore for the authors on Channel Asia sites -->
			<a href="/author/1950359870/peter-wayner/articles">Peter Wayner (InfoWorld)</a>
		
		</span>

		
			<span class="art-date" itemprop="datePublished">24 March, 2020 04:00</span>
		
	</div>

	<ul class="art-share">
		<!-- <li class="comments_li"><a class="comments" href="#comments" data-disqus-identifier="/article/672109/">0</a></li> -->
		<li class="facebook_li"><a data-action="Like" data-label="Facebook" target="_blank" class="facebook" href="http://www.facebook.com/sharer.php?u=http%3A//www.arnnet.com.au/article/672109/can-apis-copyrighted/&amp;amp;t=Can%20APIs%20be%20copyrighted%3F"></a></li>
		<li class="linkedin_li">
			<a data-action="share" data-label="LinkedIn" target="_blank" class="linkedin" href="http://www.linkedin.com/shareArticle?mini=true&amp;url=http%3A//www.arnnet.com.au/article/672109/can-apis-copyrighted/&amp;title=Can%20APIs%20be%20copyrighted%3F">
				<span class="s">share</span>
			</a>
		</li>
		<li class="twitter_li">
			<a data-action="Tweet" data-label="Twitter" target="_blank" class="twitter" href="http://twitter.com/share?text=Can%20APIs%20be%20copyrighted%3F&amp;url=http%3A//www.arnnet.com.au/article/672109/can-apis-copyrighted/">

			</a>
		</li>
		<!-- <li class="gplus_li">
			<a data-action="+1" target="_blank" data-label="Google+" class="gplus" href="https://plus.google.com/share?url=http%3A//www.arnnet.com.au/article/672109/can-apis-copyrighted/">
			
			</a>
		</li> -->
		
		<li class="print_li">
			<a class="line print" title="print this article" href="/article/print/672109/can-apis-copyrighted/" rel="nofollow">
				print
			</a>
		</li>
		
		<li class="email_li">
			<a class="line email" title="email this article" href="mailto:?subject=Can%20APIs%20be%20copyrighted%3F&amp;amp;body=http%3A//www.arnnet.com.au/article/672109/can-apis-copyrighted/">
				email
			</a>
		</li>
	</ul>
</div>
<script type="text/javascript" language="JavaScript" src="https://www.idgcdn.com.au/compressor-staticfiles/article/social.js?release=20200406163827"></script>
<script>
// var social_float_disable = true;
</script>

        

        
        


        <div class="art-header_extra">
          
          



<aside class="dir-related">
	<h3 class="dir-related_label">Distributors</h3>
	<ul class="dir-related_list">
		
		<li><a href="/distributor_directory/distributor/2141853128/nextgen">NEXTGEN</a></li>
		
		<li><a href="/distributor_directory/distributor/1795960311/synnex">Synnex</a></li>
		
		<li><a href="/distributor_directory/distributor/2141854453/tech-data-australia">Tech Data Australia</a></li>
		
		<li><a href="/distributor_directory/distributor/1422113729/westcon-comstor">Westcon – Comstor</a></li>
		
	</ul>
</aside>





<aside class="dir-related">
	<h3 class="dir-related_label">Vendors</h3>
	<ul class="dir-related_list">
		
		<li><a href="/vendor_directory/491267544/oracle">Oracle</a></li>
		
	</ul>
</aside>





          <a href="#art-comments_672109" data-disqus-identifier="/article/672109/" class="art-comment_count">Comments</a>
        </div>

      </header>

      <div itemprop="articleBody" class="art-body body">

      
      
      
      
      <div class="story_images nocaption">
        <figure>
          
          <img alt="" src="https://d2bs8hqp6qvsw6.cloudfront.net/article/images/740x500/dimg/dreamstime_s_142499163.jpg">
          

          
          
          <span class="image-license">
            
            <span>Credit:  Dreamstime </span>
            
            
          </span>
          

        </figure>
        

        
      </div>
      
      
      



      

      













	

<p>The great billion dollar sumo match between <a href="https://www.infoworld.com/article/3527410/oracle-v-google-java-copyright-battle-enters-final-round.html" target="_blank">Oracle and Google</a> has been winding its way through the courts and is just about to reach the final round where the US Supreme Court will decide, among other things, whether an API can be copyrighted.</p><p>There are a number of nuances to the case including accusations of pure plagiarism, but the tantalising question about APIs and whether they might be copyrightable is giving programmers and their good friends, the lawyers, something to argue about for many billable hours.</p><p>On one side of the debate are programmers who are wondering if there’s one more legal gotcha that they’ve got to worry about when writing their code. Is this another reason to sit through more meetings with more lawyers?</p>
<div style="line-height:0;z-index:2000;position:relative">
<div class="gpt-ad" data-gpt-ad-unit-path="/8456/IDG.AU_B2B_ARNnet.com.au/software_section" data-gpt-size-mapping="[[[0, 0], [[3, 3]]]]" data-gpt-sizes="[[3, 3]]" data-gpt-targeting='{"node": ["672109"], "idgau_tax": ["news"], "site": ["arn"], "sect": ["software"], "idgau_search_referrer": ["no"], "type": ["article"]}' id="gpt-ad-interscroller-2068735">
</div>
<div class="house-slot" data-min-width="" data-name="" style="display:none">
</div>
</div>
<p>On the other side are the very same programmers who are putting in long days creating wonderful APIs and want to be rewarded with control over their baby. In other words, it’s an opportunity for the same lawyers to validate the programmers’ creativity and bring in licensing fees.</p><p>The case has been decided both in Google’s and in Oracle’s favour by different courts at different stages. In the <a href="http://www.cafc.uscourts.gov/sites/default/files/opinions-orders/17-1118.Opinion.3-26-2018.1.PDF" rel="nofollow" target="_blank">latest ruling</a>, the Court of Appeals for the Federal Circuit decided “that Google’s use of the Java API packages was not fair as a matter of law” and started the process of assessing damages.</p><p>Now the Supreme Court has scheduled hearings for March 24, 2020, and may finally decide the case. Maybe not forever, though, because forever is a long time.</p><p>The details of the battle between Google and Oracle will be of interest to lawyers and programmers who are immersed in Java development for the Android platform, but the larger question about copyrightability affects almost every programmer who calls hundreds or millions of APIs almost every day.</p><p>Aside from a few coders working at the lowest level of machine code, APIs are a part of almost every programmer’s daily existence.</p><p>Should APIs be copyrighted? How much power should programmers have over others? Here are N different reasons that argue both for and against giving the programmers the power over their APIs.</p><p><strong>For: Programmers wrote it</strong></p><p>The law is very clear about copyright. If a programmer writes down some code, the programmer owns the copyright on the work. The programmer may choose to trade that copyright for a paycheck or donate it to an open source project, but the decision is entirely the programmer’s.</p><p>An API may not be standalone code, but it’s still the hard work of a person. The programmers will make many creative decisions along the way about the best or most graceful way to share their computational bounty. If the developers are going to sit through all of those meetings and endure all of those code reviews, the developers deserve to be recognised for the toil with a copyright.</p><p><strong>Against: APIs are functional</strong></p><p>APIs are purely functional and the copyright law doesn’t protect the merely functional expressions. If you say “yes” to a flight attendant offering you coffee, you’re not plagiarising or violating the copyright of the ancient human who coined the word “yes.” You’re just replying in the only way you can.</p><p>Imagine if some clever car manufacturer copyrighted the steering wheel and the location of the pedals. The car manufacturers have plenty of ways to get creative about fins and paint colours. Do they need to make it impossible to rent or borrow a car without a lesson on how to steer it?</p><p>The law recognises that there are good reasons not to allow copyright to control functional expressions. An API isn’t a great work of code, it’s just the functional set of buttons that set the code in motion.</p><p><strong>For: Functions evolve too</strong></p><p>My new car is semi-autonomous and when I’m on the highway I don’t need to use any of the pedals. I simply toggle some switches on the steering wheel to adjust the speed and the following distance. The computer does the rest.</p><p>Just because the car industry clung to the standard locations of steering wheels and pedals for decades doesn’t mean that there is no room for improvement. Car companies are exploring using joy sticks, levers, and other controls, and they should be rewarded for their effort.</p><p>It’s often surprising how many ways coders can express the same basic operations with their own personal style. When I teach programming classes, it’s usually simple to spot copying immediately because of the differences in the way that each programmer answers the questions.</p><p>Even the simplest questions have dozens or even hundreds of solutions that achieve the same end. Yes, the API may be just a functional gateway to a huge block of code, but we should reward the creative decisions embodied in it.</p><p><strong>Against: Only one way</strong></p><p>Sometimes there’s only one way to do something and the copyright law has an exemption for moments like that. The doctrine of “merger” offers a limited escape hatch from copyright control when there are no other options. If there are only a few ways to express an idea, the idea is said to “merge” with the few options available.</p><p>Since the law is said to prevent copying the expressions of ideas and not the ideas themselves, the merged ideas must be open to use by everyone. Anyone trying to duplicate a block of code is going to want to duplicate the API too.</p><p><strong>For: APIs are closer to code than ever</strong></p><p>At one point, an API was just the top layer of a huge piece of work. The cherry on the top of the sundae. The part of the iceberg sticking above the water line. No more.</p><p>Thanks to automation and clever developers, much of the code under the API is often boilerplate. It’s more and more common for most of the work to go into crafting the API, while the rest of it is filled in by some combination of serverless systems, frameworks, CMS tools, and smart databases.</p><aside id="brand-post-promo-placeholder-slot"></aside><p>The developer’s architectural choices of input format, workflow, state transitions, and responses are often the biggest decisions made along the way. Many of the big blocks of code underneath are a mixture of libraries and automatically generated functions. Oh sure, there can be some real bursts of creativity deep in the stack, but it’s a mistake to dismiss the art of creating the API.</p><p><strong>Against: Titles aren’t copyrightable</strong></p><p>The copyright law recognises that sometimes tight regulation makes work impossible. While writers will spend hours searching for the perfect short, pithy phrase to name their book or movie, there just aren’t enough short, pithy phrases to go around. And so the courts decided long ago that titles can’t be copyrighted.</p><p>There are at least 19 versions of a book called “The Night Shift” and three versions of “Winter’s Tale,” for example, <a href="https://www.everythingzoomer.com/arts-entertainment/2018/01/10/fire-and-fury-and-7-other-famous-books-that-share-the-same-title/" rel="nofollow" target="_blank">all written by different authors</a>.</p><p>Functions have names and these names, like titles, are in short supply. There are only a few ways to say “print” or “find data.” Insisting that every programmer create a clever new set of function names may have been possible in the 1970s when the first programming language was created but there have been a lot of functions written since then.</p><p><strong>For: APIs are more than titles</strong></p><p>Of all the work that goes into writing an API, choosing pithy names for the function calls is probably the least complicated. Humourless saps doing code review will probably get upset when you try to be clever or humorous, so most programmers stow the puns and Dad jokes knowing they’ll never pass.</p><p>The real work goes into the data structures, the format, and the options available to whomever is calling upon the API. Once these are decided, the names and titles practically write themselves.</p><p><strong>Against: Fair use protects limited copying</strong></p><p>An API is just a small part of a large block of code. Copyright law has long encouraged limited copying under the doctrine of “fair use.” This is the same principle that allows students, journalists, and other writers to paste verbatim quotes into their own documents without worrying about being sued for infringement.</p><p><strong>For: Fair use is not for commercial competition</strong></p><p>The question of what constitutes fair use has been a question for the courts for decades. In general, the doctrine is intended to help customers work with their books, music, or images without infringing. Quoting a block of text in a scholarly essay or a newspaper article is welcomed when the new author adds insight or commentary, increasing society’s understanding. There are also fair use exemptions for making backup copies of digital works.</p><p>The extent of this fair use, though, is limited by the amount it could hurt the sales of the original work. If the API is copied to compete commercially with the original work and displace it in the marketplace, the law is less welcoming.</p><p><strong>Against: Open APIs are about freedom</strong></p><p>APIs are a close cousin to open source. They’re born of the same urge to link, connect, and integrate. The developers create an API to allow others to use it. Letting others clone APIs without permission opens up the world to more healthy competition.</p><p>Others can create competing blocks of code with the same API and this will spur innovation. Developers shouldn’t spend their time trying to lock down their API; they should spend it on improving the code behind the API.</p><p><strong>For: Open source likes copyrights</strong></p><p>There are many definitions about what it means to be “open” on the Internet. Some of them border on anarchy, but the most successful and fruitful are the open source teams, which often depend upon the law more than most realise. All of the major open source licenses rely upon copyright law for their strength. If the copyright law were weakened, the open source licenses would be too.</p><p><strong>Against: Copyrighting APIs would destroy the Internet</strong></p><p>The Internet relies upon cooperation and anything that gets in the way of cooperation will make it harder for everyone to do cool things. Adding another layer of law to the APIs will force everyone to stop coding and start arguing over who has the right to do what. Work wouldn’t get done. Services would shut down as everyone sued everyone else.</p><p><strong>For: Copyrightable APIs have been the law</strong></p><p>Since Oracle won the last round, the decision became the guiding light for the lawyers until the Supreme Court weighs in. The Internet didn’t stop functioning. The APIs did not close up. The bits kept flowing.</p><p><strong>Meh: Copyrightable APIs are no big deal</strong></p><p>The Supreme Court’s forthcoming decision will certainly affect the shareholders at Google and Oracle. It will also give law schools new material to debate for decades. But most programmers won’t feel the effects for the simple reason that most API creators want people to use their API.</p><p>Perhaps they created the interface to make money. Perhaps they have information to share. But most APIs are designed to be used widely with no restrictions on the code.</p><p>Still, the decision will be important for those moments when the hearts aren’t so pure and open. If you’re going to be using another block of code and relying upon it to do something essential, it’s worth examining the license and considering your motives.</p><p>Are you trying to educate and illuminate, one of the major foundations for the fair use exemptions that the law recognises? Or are you just trying to avoid sharing your revenue with someone else, the someone who created the code you’re about to rely upon?</p><p>If you’re working against another person’s best interests, if you’re just being greedy, there’s a good chance the law will sense it and punish you. The good news is that most API authors want their API to be used and most programmers want to form a long-term and mutually sustainable way by abiding by the wishes of the API’s creator. </p>





      




<div id="article_bottom_promo">

	<a href=""><b> </b></a>
	<br> <center>
<a href="https://www.surveymonkey.com/r/2MC3P26" target="_blank"><img src="https://demo.idg.com.au/arn/ARNSurvey.png" width="280"></img></a>
</center>

</div>





      

        
      





<aside class="readmore" id="brand-post-in-article-promo">
  <div class="nocontent">
  <a class="image placeholder" href="https://www.arnnet.com.au/poly/" onclick="trackBrandPostNativeAdLink(670858);">
    <img src="https://d2bs8hqp6qvsw6.cloudfront.net/brand-post/logo/80x80/brand_posts/brand/poly-logo.png" />
  </a>

  <span class="text">
    <img class="brandpost_logo" src="https://d2bs8hqp6qvsw6.cloudfront.net/dimg/90x30/brand_post/post_type/brandpost_type.png">
    <a href="https://www.arnnet.com.au/poly/" onclick="trackBrandPostNativeAdLink(670858);">Rethink the workplace of the future</a><br/>
  </span>

  <a class="more" href="/brand-post/255/poly/" onclick="trackBrandPostNativeAdLink(670858);">More from Poly</a>

  
  </div>
</aside>




<script type="text/javascript">
$(document).ready(function() {
  if(document.getElementById("brand-post-promo-placeholder-slot") !== null) {
    insertBrandPostReadMoreSlot();
  } else {
    insertBrandPostArticleMiddle();
  }
});

function insertBrandPostReadMoreSlot() {
  $('#brand-post-promo-placeholder-slot').replaceWith($('#brand-post-in-article-promo'));
}

function insertBrandPostArticleMiddle() {
  var pos = $('article.full .body > .storybody').length;
  if (pos > 5) {
    pos = Math.round(pos / 2);
  }
  
  $('article.full .body > .storybody').each(function(index, object){  
    if (index == pos) {
      $(this).after($('#brand-post-in-article-promo'));
    }
  });
}
</script>




<script type="text/javascript">
function trackBrandPostNativeAdLink(nid) {
  ga("send", "event", 'Brand Posts', 'Brand Post native ad click', 'brand-post-nid-' + nid, {'nonInteraction': 1});
}
</script>



      


      
      

      
      <section class="art-connect">
	<div class="art-connect_social">
		<h3>Follow Us</h3>
		<ul class="art-connect_social_links"><li><a class="art-connect_social_icon art-connect_twitter" href="https://twitter.com/arnnet" target="_blank">Twitter</a></li><li><a class="art-connect_social_icon art-connect_linkedin" href="https://www.linkedin.com/company/3301666/" target="_blank">LinkedIn</a></li></ul>
	</div>

	

<div class="qs-article_widget">
  <h3>Join the  newsletter!</h3>
  <!-- <small>The premier provider of daily news to the IT channel, covering business, technology, products, and services.</small> -->

  <form id="qs-article" action="/newsletter/quick-subscription/">
    
    <input type="hidden" name="newsletter" value="67" id="id_newsletter" />
    <input type="hidden" value="https://www.arnnet.com.au/article/672109/can-apis-copyrighted/" name="signup_url">

    

    <div class="qs-anonymous" id="qs-anonymous">
      <input type="email" name="email" required placeholder="Email address" class="qs-textfield" id="id_email" />
      <button type="button" class="qs-btn primary" id="qs-btn_anonymous">Join</button>
    </div>


    <!-- email signup section end -->

    <div class="reg-or">
      <span>Or</span>     
    </div>

    <!-- social media signup section -->
    <div id="social-login-wrap">
      <div id="social-login-con">
        <ul>
          <li>
            <a class="reg-linkedin_link" href="/social/login/linkedin-oauth2/?next=/user/mailing_list/">
              <span >
                <svg xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 24 24"><path d="M4.98 3.5c0 1.381-1.11 2.5-2.48 2.5s-2.48-1.119-2.48-2.5c0-1.38 1.11-2.5 2.48-2.5s2.48 1.12 2.48 2.5zm.02 4.5h-5v16h5v-16zm7.982 0h-4.968v16h4.969v-8.399c0-4.67 6.029-5.052 6.029 0v8.399h4.988v-10.131c0-7.88-8.922-7.593-11.018-3.714v-2.155z"/></svg>
              </span>
              Sign in with LinkedIn
            </a>
          </li>
          <li>
            <a class="reg-facebook_link" href="/social/login/facebook/?next=/user/mailing_list/">
              <span>
                <svg xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 24 24"><path d="M9 8h-3v4h3v12h5v-12h3.642l.358-4h-4v-1.667c0-.955.192-1.333 1.115-1.333h2.885v-5h-3.808c-3.596 0-5.192 1.583-5.192 4.615v3.385z"/></svg>
              </span>
              Sign in with Facebook
            </a>
          </li>
        </ul>
      </div>
    </div>
    <!-- social media signup section -->

    <div id="qs-terms">
      <p>Sign up to gain exclusive access to email subscriptions, event invitations, competitions, giveaways, and much more.</p>
      <p>Membership is free, and your security and privacy remain protected. View our <a href="/privacy/">privacy policy</a> before signing up.</p>
    </div>
  </form>

  <div class="qs-message" id="qs-message">Error: Please check your email address.</div>
</div>

<script type="text/javascript">
$(document).ready(function() {
  var wrap = $('.qs-article_widget');
  wrap.css('background', wrap.data('color-initial'));
  
  var form = $('#qs-article');
  
  $('#qs-btn_change_email').click(function() {
    $('#qs-registered').slideUp();
    $('#qs-anonymous').slideDown();
  });
  
  $('#qs-btn_anonymous, #qs-btn_registered', form).click(function() {
    form.submit();
  });
  
  // $("#qs-message").click(function() {
  //   $(this).fadeOut();
  // });
  
  form.submit(function(e) {
    e.preventDefault();
    
    var data = {};
    $('#qs-article').serializeArray().map(function(x) {
      data[x.name] = x.value;
    });
    
    $('#qs-message').hide();
    
    $.ajax({
      url: form.attr('action'),
      type: 'POST',
      dataType: 'json',
      data: data,
      error: function(xhr) {
        var data = JSON.parse(xhr.responseText);
        alert(data.message);
      },
      success: function(data) {
        if (data.success) {
          $('#id_email', form).val('');
          // wrap.css('background-color', wrap.data('color-success'));
          // $('#qs-message').css('color', wrap.data('color-success'));
          $('#qs-registered, #qs-anonymous').slideUp();
        }
        $('#qs-message').html(data.message).slideDown();
      }
    });
  });
});
</script>


</section>

      


        
      
      <p class="tags">
        Tags <a href="/tag/copyright/">copyright</a><a href="/tag/oracle/">Oracle</a><a href="/tag/google/">Google</a><a href="/tag/api/">API</a>
      </p>
      
      
      
      



      

<aside class="art-readnext readnext">
	<div class="nocontent">
	<h2 class="lo-title center">Read next</h2>
	<ul>
		
		
		
		<li>
			
			
	        

			<a class="image" href="/article/672325/5-tips-finding-keeping-top-developer-talent/"><img class="lazyload" src="https://www.idgcdn.com.au/compressor-staticfiles/lazysizes/placehold.png?release=20200406163827" data-src="https://d2bs8hqp6qvsw6.cloudfront.net/article/images/190x190/dimg/dreamstime_s_158245501_1.jpg"></a>
			<h3><a href="/article/672325/5-tips-finding-keeping-top-developer-talent/">5 tips for finding and keeping top developer talent</a></h3>

			

		</li>
		
		<li>
			
			
	        

			<a class="image" href="/article/672547/servian-gains-google-cloud-services-gong/"><img class="lazyload" src="https://www.idgcdn.com.au/compressor-staticfiles/lazysizes/placehold.png?release=20200406163827" data-src="https://d2bs8hqp6qvsw6.cloudfront.net/article/images/190x190/dimg/tony_nicol.jpg"></a>
			<h3><a href="/article/672547/servian-gains-google-cloud-services-gong/">Servian gains Google Cloud services gong</a></h3>

			

		</li>
		
		

		
		
		
		
		<li class="gallery">
			<a class="image" href="/slideshow/672070/arn-kicks-off-awards-season-2020-judges-lunch/"><img src="https://d2bs8hqp6qvsw6.cloudfront.net/article/images/190x190/dimg/arn_judges_lunch_2020-1978.jpg"></a>
			<h3><a href="/slideshow/672070/arn-kicks-off-awards-season-2020-judges-lunch/">ARN kicks off awards season in 2020 with Judges&#39; Lunch</a></h3>
		</li>
		
		
		
	</ul>
	</div>
</aside>



      </div><!-- body -->

    </article>


    <div class="art-sidebar">
      
      


  <aside class="rhs-follow-us">
    <h2 class="lo-title">Follow us</h2>
    <ul class="">
      <li class="twitter"><a href="https://twitter.com/ARNnet/" target="_blank" title="Twitter">Twitter</a></li>
     <li class="facebook"><a href="https://www.facebook.com/ARNnet" target="_blank" title="Facebook">Facebook</a></li>
     <li class="linkedin"><a href="https://www.linkedin.com/company/3301666/" target="_blank" title="LinkedIn">LinkedIn</a></li>
     <li class="rss"><a href="/rss/tax/news/" target="_blank" title="RSS">RSS</a></li>
    </ul>
  </aside>



  
  
  <div class="rhs_boombox">
<div class="gpt-ad" id="gpt-ad-right-hand-side-story-list-2068735" data-gpt-ad-unit-path="/8456/IDG.AU_B2B_ARNnet.com.au/software_section" data-gpt-sizes="[[300, 250], [300, 600]]" data-gpt-targeting='{&quot;node&quot;: [&quot;672109&quot;], &quot;idgau_tax&quot;: [&quot;news&quot;], &quot;site&quot;: [&quot;arn&quot;], &quot;sect&quot;: [&quot;software&quot;], &quot;idgau_search_referrer&quot;: [&quot;no&quot;], &quot;type&quot;: [&quot;article&quot;]}' data-gpt-size-mapping="[[[610, 600], [[300, 600], [300, 250]]], [[0, 0], [[300, 250]]]]">
</div>
<div class="house-slot" style="display:none" data-name="" data-min-width="">

</div>

</div>
  
  
  


  
    



<div class="module-rhs-brandpost">
  <h2 class="lo-title">Brand Post</h2>
  <article>
    
    
    <a class="main-img" href="/brand-post/content/672528/connecting-businesses-governments-and-communities-in-uncertain-times/" onclick="trackBrandPostNativeAdLink(672528);">
      <img src=/dimg/300x300/dimg/dreamstime_l_168022371.jpg>
    </a>
    
    
    <h3 class="title">
      <a href="/brand-post/content/672528/connecting-businesses-governments-and-communities-in-uncertain-times/" onclick="trackBrandPostNativeAdLink(672528);">
        Connecting businesses, governments, and communities in uncertain times
      </a>
    </h3>
   
    
    <p class="description"> 
      Life’s complicated at the best of times.
    </p>
    
    <div class="sponsor">
      <span>Sponsored By</span>
      <a href="/brand-post/184/vocus-communications/" title="Vocus Communications" onclick="trackBrandPostNativeAdLink(672528);">
          <img src="https://d2bs8hqp6qvsw6.cloudfront.net/brand-post/logo/80x80/brand_posts/brand/vocus-logo-dark-blue-cmyk-highres.png"  alt="Vocus Communications"/>
      </a>
    </div>
  </article>
</div>







<script type="text/javascript">
function trackBrandPostNativeAdLink(nid) {
  ga("send", "event", 'Brand Posts', 'Brand Post native ad click', 'brand-post-nid-' + nid, {'nonInteraction': 1});
}
</script>


  
  
  

  
  
  

  
  <aside class="rhs_block directory_search dir1" >
    <h2 class="lo-title">Distributor Directory</h2>
    <p class="desc">Your essential guide to Australian Distributors</p>
    <ul class="rotate-imgs">
      <li class="hidden">
        <a href="#" class="dir-link"> 
          <img src="" alt="" class="dir-img">
        </a>
      </li>
      <li class="hidden">
        <a href="#" class="dir-link">
          <img src="" alt="" class="dir-img">
        </a>
      </li>
    </ul>
    <form action="/distributor_directory/search" method="get">
      <input placeholder="Search distributors" type="text" name=q size=35 />
      <input type="submit" Value="Search" />
    </form>
    <p class="browse">
      Find distributors by <a class="dist" href="http://www.arnnet.com.au/distributor_directory/by_name">name</a> - 
      <a class="dist" href="http://www.arnnet.com.au/distributor_directory/vendors">vendor</a> -
      <a class="dist" href="http://www.arnnet.com.au/distributor_directory/office_location">location</a>
    </p>
  </aside>
  


  
  <aside class="rhs_block directory_search dir2" >
    <h2 class="lo-title">Vendor Directory</h2>
    <p class="desc">Your essential guide to Australian Vendors</p>
    <ul class="rotate-imgs">
      <li class="hidden">
        <a href="" class="dir-link" > 
          <img src="" alt="" class="dir-img">
        </a>
      </li>
      <li class="hidden">
        <a href="" class="dir-link" >
          <img src="" alt="" class="dir-img">
        </a>
      </li>
    </ul>
    <form action="/vendor_directory/search/" method="get"><input type='hidden' name='csrfmiddlewaretoken' value='t5Mw6kieYN0UOoa7NEzidJOGiwJWa18ak47GjqIwA5kffEz25YHl3vfP2pNvjqb4' />
      <input placeholder="Search vendors" type="text" name="q" size="35" />
      <input type="submit" value='Search' />
    </form>
    <p class="browse">
      Find vendors by <a class="dist" href="http://www.arnnet.com.au/vendor_directory/by_name/">name</a> -
      <a class="dist" href="http://www.arnnet.com.au/vendor_directory/">category</a> 
    </p>
  </aside>
  
  
  <aside>
    <h2 class="lo-title">Brand Pages</h2>
    <ul class="related_list whitepapers brandpages">
      <li>
        <a class="image" href="/brand-post/content/659355/grow-your-business-with-edge-computing-how-apc-by-schneider-electric-ensures-success/">
          <img src="/brand-post/logo/100x100/brand_posts/brand/schneider-electric-logo.png" alt="APC by Schneider">
        </a>
        <h3>
          <a href="/brand-post/content/659355/grow-your-business-with-edge-computing-how-apc-by-schneider-electric-ensures-success/">
            Grow your business with Edge Computing:<br>How APC by Schneider Electric ensures success
          </a>
        </h3>
      
      </li>
      <li>
        <a class="image" href="/brand-post/content/667765/driving-new-business-through-docusign/">
          <img src="https://d2bs8hqp6qvsw6.cloudfront.net/brand-post/logo/80x80/brand_posts/brand/ds_logo_black_rgb_2x_1.png" alt="DocuSign">
        </a>
        <h3>
          <a href="/brand-post/content/667765/driving-new-business-through-docusign/">
            Driving new business through DocuSign
          </a>
        </h3>
      
      </li>
    </ul>
  </aside>
  
  

  
<section class="lo-rhs_upcoming">
	
	




	
</section>
<section class="lo-rhs_slideshows">
	<div class="nocontent">
	<h2 class="lo-title">Slideshows</h2>
	
	
	
	


<article class="lo-slideshow">
    
       
    <img class="lo-slideshow_image lazyload" src="https://www.idgcdn.com.au/compressor-staticfiles/lazysizes/placehold.png?release=20200406163827" data-src="https://d2bs8hqp6qvsw6.cloudfront.net/dimg/540x540/dimg/arn_judges_lunch_2020-1978.jpg" alt="ARN kicks off awards season in 2020 with Judges&#39; Lunch">
    <header class="lo-slideshow_header">
        
        <h3 class="lo-slideshow_title">ARN kicks off awards season in 2020 with Judges&#39; Lunch</h3>
        <p class="lo-slideshow_summary">ARN kick-started its 2020 awards season with its annual Judges’ Lunch in Sydney on 13 March, welcoming current and new judges to the panel. The judges came together in recognition of their involvement in this year&#39;s ARN Innovation Awards and Women in ICT Awards programs, both of which honour outstanding achievements by individuals and organisations in the IT channel industry. Photos by Ashley Mar.​</p>
    </header>
    <a class="lo-slideshow_link" href="/slideshow/672070/arn-kicks-off-awards-season-2020-judges-lunch/">ARN kicks off awards season in 2020 with Judges&#39; Lunch</a>
    
    
</article>


	
	


<article class="lo-slideshow">
    
       
    <img class="lo-slideshow_image lazyload" src="https://www.idgcdn.com.au/compressor-staticfiles/lazysizes/placehold.png?release=20200406163827" data-src="https://d2bs8hqp6qvsw6.cloudfront.net/dimg/540x540/dimg/kn2_9767_1.jpg" alt="In pictures: Nextgen Leadership Forum and Summer Party 2020">
    <header class="lo-slideshow_header">
        
        <h3 class="lo-slideshow_title">In pictures: Nextgen Leadership Forum and Summer Party 2020</h3>
        <p class="lo-slideshow_summary">Nextgen Distribution held its second Leadership Forum in conjunction with its latest annual Summer Party event on 13 February in Sydney. Drawing upon the theme, &#39;leading through adversity with diversity,&#39; the Leadership Forum featured keynotes and panellists including NSW Rural Fire Service Commissioner Shane Fitzsimmons; former Governor-General and Chief of the Defence Force Peter Cosgrove; Micro Focus A/NZ managing director Peter Fuller; and Vocus CEO Kevin Russell, among others, discussing leadership in adversity and diversity leadership. Photos by Kwa Nguyen.​</p>
    </header>
    <a class="lo-slideshow_link" href="/slideshow/671105/pictures-nextgen-leadership-forum-summer-party-2020/">In pictures: Nextgen Leadership Forum and Summer Party 2020</a>
    
    
</article>


	
	


<article class="lo-slideshow">
    
       
    <img class="lo-slideshow_image lazyload" src="https://www.idgcdn.com.au/compressor-staticfiles/lazysizes/placehold.png?release=20200406163827" data-src="https://d2bs8hqp6qvsw6.cloudfront.net/dimg/540x540/dimg/vocus_nex_gen_arn_rt_2019-7136.jpg" alt="Driving value within the modern workplace">
    <header class="lo-slideshow_header">
        
        
        
        <h3 class="lo-slideshow_title">Driving value within the modern workplace</h3>
        <p class="lo-slideshow_summary">This roundtable, held in association with Vocus and hosted by GenNet, examined why modern collaboration platforms are essential in today’s workplace and discussed how one such platform, Microsoft Teams, can deliver the functionality to meet the needs of the modern enterprise.</p>
    </header>
    <a class="lo-slideshow_link" href="/slideshow/670505/driving-value-within-modern-workplace/">Driving value within the modern workplace</a>
    
    
</article>


	
	
	</div>
</section>


  
  
  <div class="rhs_block rhs_block_ad">
    <div class="content">
<div class="gpt-ad" id="gpt-ad-right-hand-side-feature-box-2068735" data-gpt-ad-unit-path="/8456/IDG.AU_B2B_ARNnet.com.au/software_section" data-gpt-sizes="[[300, 150]]" data-gpt-targeting='{&quot;node&quot;: [&quot;672109&quot;], &quot;idgau_tax&quot;: [&quot;news&quot;], &quot;site&quot;: [&quot;arn&quot;], &quot;sect&quot;: [&quot;software&quot;], &quot;idgau_search_referrer&quot;: [&quot;no&quot;], &quot;type&quot;: [&quot;article&quot;]}' data-gpt-size-mapping="[[[0, 0], [[300, 150]]]]">
</div>
<div class="house-slot" style="display:none" data-name="" data-min-width="">

</div>

</div>
  </div>
  
  


  
  
  <div class="rhs_block rhs_boombox">
    <div class="content">
<div class="gpt-ad" id="gpt-ad-right-hand-side-boombox-standard-2068735" data-gpt-ad-unit-path="/8456/IDG.AU_B2B_ARNnet.com.au/software_section" data-gpt-sizes="[[300, 250], [300, 600]]" data-gpt-targeting='{&quot;node&quot;: [&quot;672109&quot;], &quot;idgau_tax&quot;: [&quot;news&quot;], &quot;site&quot;: [&quot;arn&quot;], &quot;sect&quot;: [&quot;software&quot;], &quot;idgau_search_referrer&quot;: [&quot;no&quot;], &quot;type&quot;: [&quot;article&quot;]}' data-gpt-size-mapping="[[[610, 600], [[300, 600], [300, 250]]], [[0, 0], [[300, 250]]]]">
</div>
<div class="house-slot" style="display:none" data-name="" data-min-width="">

</div>

 </div>
  </div>
  
  

  
  <div class="rhs_block" id="rhs_iasset_index" class="rhs_iasset_index">
  
  
  <a href="http://www.iasset.com/" target="_blank">
  <img class="rhs_iasset_index_img lazyload" src="https://www.idgcdn.com.au/compressor-staticfiles/lazysizes/placehold.png?release=20200406163827" data-src="https://d2bs8hqp6qvsw6.cloudfront.net/dimg/300x300/iasset/promos/iasset_promo_78">
  </a>
  </div>
  
  

  
    <div id="job-widget-container"></div>
  

  



	

<aside>
	<div class="nocontent">
	<h2 class="lo-title">Related Whitepapers</h2>
	<ul class="related_list whitepapers">
	
	
	<li>
		<a class="image" href="/whitepaper/374266/the-achilles-heel-of-next-gen-firewalls-results-of-a-global-study-of-3100-it-managers-in-12-countrie/?type=other&amp;arg=0&amp;location=rhs_related_whitepaper"><img src="https://d2bs8hqp6qvsw6.cloudfront.net/whitepaper/thumbnail/40x60/whitepapers/thumbnails/sophos_2.jpg" /></a>
		<h3><a href="/whitepaper/374266/the-achilles-heel-of-next-gen-firewalls-results-of-a-global-study-of-3100-it-managers-in-12-countrie/?type=other&amp;arg=0&amp;location=rhs_related_whitepaper">The Achilles Heel of Next-Gen Firewalls | Results of a global study of 3,100 IT managers in 12 countries</a></h3>
	</li>
	
	
	<li>
		<a class="image" href="/whitepaper/374277/the-last-switch-youll-ever-make-realising-your-network-potential/?type=other&amp;arg=0&amp;location=rhs_related_whitepaper"><img src="https://d2bs8hqp6qvsw6.cloudfront.net/whitepaper/thumbnail/40x60/whitepapers/thumbnails/the-last-switch-ebook-1.jpg" /></a>
		<h3><a href="/whitepaper/374277/the-last-switch-youll-ever-make-realising-your-network-potential/?type=other&amp;arg=0&amp;location=rhs_related_whitepaper">The last switch you’ll ever make: Realising your network potential</a></h3>
	</li>
	
	
	<li>
		<a class="image" href="/whitepaper/374278/whitepaper-atex-technology-from-getac/?type=other&amp;arg=0&amp;location=rhs_related_whitepaper"><img src="https://d2bs8hqp6qvsw6.cloudfront.net/whitepaper/thumbnail/40x60/whitepapers/thumbnails/atex_technology_whitepaper_2020v20-1.png" /></a>
		<h3><a href="/whitepaper/374278/whitepaper-atex-technology-from-getac/?type=other&amp;arg=0&amp;location=rhs_related_whitepaper">Whitepaper: ATEX Technology from Getac</a></h3>
	</li>
	
	</ul>
	</div>
</aside>




      
    </div>



    <div class="art-extra">

    
    <div class="art-comments" id="art-comments_672109">
    <a class="art-comment_show" data-disqus-identifier="/article/672109/" data-disqus-shortname="arnnet" href="#">Show Comments</a>
<div id="disqus_thread" data-disqus-shortname="arnnet" data-disqus-identifier="/article/672109/"></div>
<script type="text/javascript">
var disqus_shortname = 'arnnet';
var disqus_identifier = '/article/672109/';
var disqus_init = false;
function disqus_config() {
	this.callbacks.onReady = [function() {
		if (disqus_init) return;
		disqus_init = true;

		if ($('.art-articles_wrap_infinite').length == 0) return;

		var comment_text = $('.art-comment_show').first().text();
		if (comment_text == '0 Comments') {
			$(".art-comment_show_activated").removeClass("art-comment_show_activated");
			$('#disqus_thread').hide();
		}
	}];
}

(function() {
	$('.art-comment_show').first().addClass('art-comment_show_activated');
	var dsq = document.createElement('script'); dsq.type = 'text/javascript'; dsq.async = true;
	dsq.src = '//' + disqus_shortname + '.disqus.com/embed.js';
	(document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(dsq);
})();
</script>
<noscript>Please enable JavaScript to view the <a href="http://disqus.com/?ref_noscript">comments powered by Disqus.</a></noscript>

    </div>
      



      

      
      <div class="lo-bottom_boombox bottom_boombox">
      
<div class="gpt-ad" id="gpt-ad-main-column-2068735" data-gpt-ad-unit-path="/8456/IDG.AU_B2B_ARNnet.com.au/software_section" data-gpt-sizes="[[300, 250], [300, 600]]" data-gpt-targeting='{&quot;node&quot;: [&quot;672109&quot;], &quot;idgau_tax&quot;: [&quot;news&quot;], &quot;site&quot;: [&quot;arn&quot;], &quot;sect&quot;: [&quot;software&quot;], &quot;idgau_search_referrer&quot;: [&quot;no&quot;], &quot;type&quot;: [&quot;article&quot;]}' data-gpt-size-mapping="[[[610, 600], [[300, 600], [300, 250]]], [[0, 0], [[300, 250]]]]">
</div>
<div class="house-slot" style="display:none" data-name="" data-min-width="">

</div>


      </div>
      


      <!-- <script type="text/javascript" src="https://www.idgcdn.com.au/compressor-staticfiles/article/article.js?release=20200406163827"></script> -->

      



      
<script type="text/javascript">
(function() {
  var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;
  po.src = 'https://apis.google.com/js/plusone.js';
  var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);
})();
</script>



    </div>

    


    
    
    <div id="leaderboard-bottom-ad" class="art-bottom_leaderboard lo-leaderboard_bottom">
<div class="gpt-ad" id="gpt-ad-bottom-banner-2068735" data-gpt-ad-unit-path="/8456/IDG.AU_B2B_ARNnet.com.au/software_section" data-gpt-sizes="[[728, 90]]" data-gpt-targeting='{&quot;node&quot;: [&quot;672109&quot;], &quot;idgau_tax&quot;: [&quot;news&quot;], &quot;site&quot;: [&quot;arn&quot;], &quot;sect&quot;: [&quot;software&quot;], &quot;idgau_search_referrer&quot;: [&quot;no&quot;], &quot;type&quot;: [&quot;article&quot;]}' data-gpt-size-mapping="[[[728, 90], [[728, 90]]], [[0, 0], []]]">
</div>
<div class="house-slot" style="display:none" data-name="" data-min-width="">

</div>

</div>  
    
    


    
    



<div class="ias-pagination" id="ias-pagination_672109">
	<a class="ias-next" data-sms="Redmond is teasing several enterprise-friendly features likely to be in the upcoming Windows 10 update, but it hasn’t committed to a release date" data-image="https://d2bs8hqp6qvsw6.cloudfront.net/dimg/200x200/dimg/windows_10_20-1_5.jpg" title="Microsoft starts to beat Windows 10 2004 drum for business" data-article-nextid="671999" href="/article/671999/microsoft-starts-beat-windows-10-2004-drum-business/">Microsoft starts to beat Windows 10 2004 drum for business</a>
</div>

    

    
    <div id="clarity-context-data_672109" data-context="{&quot;event_type&quot;: &quot;pageview&quot;, &quot;tags&quot;: [&quot;copyright&quot;, &quot;Oracle&quot;, &quot;Google&quot;, &quot;API&quot;], &quot;author&quot;: &quot;Peter Wayner&quot;, &quot;word_count&quot;: 1928, &quot;publication_datetime&quot;: &quot;2020-03-23T17:00:00+00:00&quot;, &quot;score&quot;: 1, &quot;content_type&quot;: &quot;article&quot;, &quot;content_id&quot;: 328583900}">

    



  </div><!-- art-wrap -->




</div><!-- art-articles_wrap -->










  </div><!-- site_columns_main -->
  





  <div class="clearing">&nbsp;</div><!-- This is for NN6 -->

    












</div><!-- main -->


</div><!-- skin -->


<footer class="lo-footer">
  <div class="lo-footer_content">
    <img class="lo-footer_idg" src="https://demo.idg.com.au/idg_logo_footer.gif" alt="">
    <div class="lo-footer_text">
      <p class="lo-footer_copyright">Copyright 2020 IDG Communications. ABN 14 001 592 650. All rights reserved. Reproduction in whole or in part in any form or medium without express written permission of IDG Communications is prohibited.</p>
      <div class="lo-footer_audit">
      <a href="http://www.auditbureau.org.au/edata/masthead/show/arn" target="_blank"><img src="https://demo.idg.com.au/idg/ABA_audited_website.gif" alt="ABA Audited Website"></a>
      </div>
      <p class="lo-footer_site">
      IDG Sites:
      <a href="http://www.pcworld.idg.com.au">PC World</a> | 
      <a href="http://www.goodgearguide.com.au">GoodGearGuide</a> | 
      <a href="http://www.computerworld.com/au">Computerworld Australia</a> | 
      <a href="http://www.cio.com/au">CIO Australia</a> | 
      <a href="http://www.cmo.com.au">CMO Australia</a> |
      <a href="http://www.csoonline.com/au">CSO Online</a> | 
      <!-- <a href="http://www.techworld.com.au">Techworld</a> |  -->
      <a href="http://www.cioexecutivecouncil.com.au/">CIO Executive Council</a>
      </p>
      <p class="lo-footer_links">
      Links: <a href="/privacy">Privacy Policy [Updated 13 Sep 19]</a> | <a href="http://www.idg.com.au/contacts">Advertising</a>
      </p>
    </div>
  </div>
</footer>
<div class="lo-script">
<script type="text/javascript" language="JavaScript" src="https://www.idgcdn.com.au/compressor-staticfiles/arn/arn.js?release=20200406163827"></script>
<script type="text/javascript" language="JavaScript" src="https://www.idgcdn.com.au/compressor-staticfiles/lazysizes/lazysizes.min.js?release=20200406163827"></script>

<div id="fb-root"></div>
<script>
	window.fbAsyncInit = function() {
		FB.init({appId: '105374282841262', status: true, cookie: true,
			xfbml: true});
	};
	(function() {
		var e = document.createElement('script'); e.async = true;
		e.src = document.location.protocol + '//connect.facebook.net/en_US/all.js';
		document.getElementById('fb-root').appendChild(e);
	}());
</script>


<script type="text/javascript" src="https://www.idgcdn.com.au/compressor-staticfiles/arn/js/rhs/directory_search.js?release=20200406163827"></script>
<script>

</script>


  

  <script>
    var disqus_shortname = "";
  </script>
  <script type="text/javascript" src="https://www.idgcdn.com.au/compressor-staticfiles/article/jquery.magnific-popup.min.js?release=20200406163827"></script>
  <script src="https://www.idgcdn.com.au/compressor-staticfiles/article/jquery-ias.min.js?release=20200406163827"></script>
  <script src="https://www.idgcdn.com.au/compressor-staticfiles/article/infinitescroll.js?release=20200406163827"></script>
  <script>
    ias_init('ARN');
  </script>

<div id="trackers">


<!-- Start Google Analytics  -->
<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','//www.google-analytics.com/analytics.js','ga');

ga('create', 'UA-4682930-1', 'auto');

ga('require', 'displayfeatures'); // enables demographics and interests reports


	ga('set', 'dimension1', "none");



	ga('set', 'dimension2', "peter-wayner");



	ga('set', 'dimension3', "none");



	ga('set', 'dimension4', "none");



	ga('set', 'dimension5', "anonymous");



	ga('send', 'pageview');


// pageTracker._trackPageLoadTime();


// event tracking is asynchronous
function trackEvent(category, action, label, value) {
	if (value)
		ga('send', 'event', category, action, label, value, {'nonInteraction': 1});
	else
		ga('send', 'event', category, action, label, {'nonInteraction': 1});
}



trackEvent('Content Tags', 'Tag Impression', 'copyright');

trackEvent('Content Tags', 'Tag Impression', 'oracle');

trackEvent('Content Tags', 'Tag Impression', 'google');

trackEvent('Content Tags', 'Tag Impression', 'api');

trackEvent('Brand Posts', 'Brand Post native ad impression', 'brand-post-nid-670858');

trackEvent('Brand Posts', 'Brand Post native ad impression', 'brand-post-nid-672528');



</script>
<!-- End Google Analytics -->



</div>


<div id="ad_slot"></div>


<div class="ad_scripts">

<div class="gpt-ad" id="gpt-ad-skin-2068735" data-gpt-ad-unit-path="/8456/IDG.AU_B2B_ARNnet.com.au/software_section" data-gpt-sizes="[[1600, 1]]" data-gpt-targeting='{&quot;node&quot;: [&quot;672109&quot;], &quot;idgau_tax&quot;: [&quot;news&quot;], &quot;site&quot;: [&quot;arn&quot;], &quot;sect&quot;: [&quot;software&quot;], &quot;idgau_search_referrer&quot;: [&quot;no&quot;], &quot;type&quot;: [&quot;article&quot;]}' data-gpt-size-mapping="[[[610, 100], [[1600, 1]]], [[0, 0], []]]">
</div>
<div class="house-slot" style="display:none" data-name="" data-min-width="">

</div>



<div class="gpt-ad" id="gpt-ad-over-the-page-2068735" data-gpt-ad-unit-path="/8456/IDG.AU_B2B_ARNnet.com.au/software_section" data-gpt-sizes="[[1, 1]]" data-gpt-targeting='{&quot;node&quot;: [&quot;672109&quot;], &quot;idgau_tax&quot;: [&quot;news&quot;], &quot;site&quot;: [&quot;arn&quot;], &quot;sect&quot;: [&quot;software&quot;], &quot;idgau_search_referrer&quot;: [&quot;no&quot;], &quot;type&quot;: [&quot;article&quot;]}' data-gpt-size-mapping="[[[610, 610], [[1, 1]]], [[0, 0], []]]">
</div>
<div class="house-slot" style="display:none" data-name="" data-min-width="">

</div>



<div class="gpt-ad" id="gpt-ad-gumgum-in-image-ad-2068735" data-gpt-ad-unit-path="/8456/IDG.AU_B2B_ARNnet.com.au/software_section" data-gpt-sizes="[[12, 12]]" data-gpt-targeting='{&quot;node&quot;: [&quot;672109&quot;], &quot;idgau_tax&quot;: [&quot;news&quot;], &quot;site&quot;: [&quot;arn&quot;], &quot;sect&quot;: [&quot;software&quot;], &quot;idgau_search_referrer&quot;: [&quot;no&quot;], &quot;type&quot;: [&quot;article&quot;]}' data-gpt-size-mapping="[[[0, 0], [[12, 12]]]]">
</div>
<div class="house-slot" style="display:none" data-name="" data-min-width="">

</div>



<div class="gpt-ad" id="gpt-ad-third-party-otp-2068735" data-gpt-ad-unit-path="/8456/IDG.AU_B2B_ARNnet.com.au/software_section" data-gpt-sizes="[[15, 15]]" data-gpt-targeting='{&quot;node&quot;: [&quot;672109&quot;], &quot;idgau_tax&quot;: [&quot;news&quot;], &quot;site&quot;: [&quot;arn&quot;], &quot;sect&quot;: [&quot;software&quot;], &quot;idgau_search_referrer&quot;: [&quot;no&quot;], &quot;type&quot;: [&quot;article&quot;]}' data-gpt-size-mapping="[[[0, 0], [[15, 15]]]]">
</div>
<div class="house-slot" style="display:none" data-name="" data-min-width="">

</div>




<div class="gpt-ad" id="gpt-ad-mobile-floating-banner-2068735" data-gpt-ad-unit-path="/8456/IDG.AU_B2B_ARNnet.com.au/software_section" data-gpt-sizes="[[320, 50]]" data-gpt-targeting='{&quot;node&quot;: [&quot;672109&quot;], &quot;idgau_tax&quot;: [&quot;news&quot;], &quot;site&quot;: [&quot;arn&quot;], &quot;sect&quot;: [&quot;software&quot;], &quot;idgau_search_referrer&quot;: [&quot;no&quot;], &quot;type&quot;: [&quot;article&quot;]}' data-gpt-size-mapping="[[[600, 800], []], [[0, 0], [[320, 50]]]]">
</div>
<div class="house-slot" style="display:none" data-name="" data-min-width="">

</div>



<div class="gpt-ad" id="gpt-ad-mobile-otp-2068735" data-gpt-ad-unit-path="/8456/IDG.AU_B2B_ARNnet.com.au/software_section" data-gpt-sizes="[[2, 2]]" data-gpt-targeting='{&quot;node&quot;: [&quot;672109&quot;], &quot;idgau_tax&quot;: [&quot;news&quot;], &quot;site&quot;: [&quot;arn&quot;], &quot;sect&quot;: [&quot;software&quot;], &quot;idgau_search_referrer&quot;: [&quot;no&quot;], &quot;type&quot;: [&quot;article&quot;]}' data-gpt-size-mapping="[[[610, 610], []], [[0, 0], [[2, 2]]]]">
</div>
<div class="house-slot" style="display:none" data-name="" data-min-width="">

</div>



<div class="gpt-ad" id="gpt-ad-teads-inread-2068735" data-gpt-ad-unit-path="/8456/IDG.AU_B2B_ARNnet.com.au/software_section" data-gpt-sizes="[[18, 18]]" data-gpt-targeting='{&quot;node&quot;: [&quot;672109&quot;], &quot;idgau_tax&quot;: [&quot;news&quot;], &quot;site&quot;: [&quot;arn&quot;], &quot;sect&quot;: [&quot;software&quot;], &quot;idgau_search_referrer&quot;: [&quot;no&quot;], &quot;type&quot;: [&quot;article&quot;]}' data-gpt-size-mapping="[[[0, 0], [[18, 18]]]]">
</div>
<div class="house-slot" style="display:none" data-name="" data-min-width="">

</div>



<script type="text/javascript" src="https://www.idgcdn.com.au/compressor-staticfiles/adsmin/idg_gpt.js?release=20200406163827" charset="utf-8"></script>
<script type="text/javascript">
createAndDisplayAds();
</script>
</div>


<div class="load_dropcontent" id="load_dropcontent">
  <div class="latest" data-load="sub_news_latest">
    
    <h2>Latest News</h2>
    <dl>
      
      
        
          <dt>Apr 01</dt>
          <dd><a title="The ins and outs of high-performance computing as a service" href="/article/672396/ins-outs-high-performance-computing-service/">The ins and outs of high-performance computing as a service</a></dd>
        
          <dt>05:00AM</dt>
          <dd><a title="30 Under 30 Awards open as Emerging Leaders Forum goes virtual" href="/article/672565/30-under-30-awards-open-emerging-leaders-forum-goes-virtual/">30 Under 30 Awards open as Emerging Leaders Forum goes virtual</a></dd>
        
          <dt>01:00AM</dt>
          <dd><a title="Veritas ramps up rebates in program tweak" href="/article/672563/veritas-ramps-up-rebates-program-tweak/">Veritas ramps up rebates in program tweak</a></dd>
        
          <dt>Mar 24</dt>
          <dd><a title="Can APIs be copyrighted?" href="/article/672109/can-apis-copyrighted/">Can APIs be copyrighted?</a></dd>
        
        <dt></dt>
        <dd><a class="more" href="/tax/news">More News</a></dd>
      
    </dl>
    

    
    



<ul class="topstories">
	
	<li>
		<a class="image" href="/article/672552/ibm-ceo-we-have-to-win-the-architectural-battle-in-cloud/"><img class="lazyload" src="https://www.idgcdn.com.au/compressor-staticfiles/lazysizes/placehold.png?release=20200406163827" data-src="https://d2bs8hqp6qvsw6.cloudfront.net/promoted-content/image/180x120/promoted_content/promo/dreamstime_s_171062047.jpg"></a>
		<h3><a href="/article/672552/ibm-ceo-we-have-to-win-the-architectural-battle-in-cloud/">IBM CEO: ‘We have to win the architectural battle in cloud’</a></h3>
	</li>
	
	<li>
		<a class="image" href="/article/672525/datacom-offers-2-000-contact-centre-roles-covid-19-hit-aussies/"><img class="lazyload" src="https://www.idgcdn.com.au/compressor-staticfiles/lazysizes/placehold.png?release=20200406163827" data-src="https://d2bs8hqp6qvsw6.cloudfront.net/promoted-content/image/180x120/promoted_content/promo/datacomcrop.jpg"></a>
		<h3><a href="/article/672525/datacom-offers-2-000-contact-centre-roles-covid-19-hit-aussies/">Datacom offers 2,000 contact centre roles to COVID-19 hit Aussies</a></h3>
	</li>
	
</ul>


    
  </div>

  <dl class="latest" data-load="sub_events_latest">
    
    
    
    <h2>ARN Events</h2>
    
    <dt>16 Jun</dt>
    <dd>
    
    <a title="ARN Emerging Leaders 2020" href="https://www.arnnet.com.au/emerging_leaders/">ARN Emerging Leaders 2020</a>
    
    </dd>
    
    <dt>01 Nov</dt>
    <dd>
    
    <a title="EDGE 2020" href="https://www.arnnet.com.au/edge/">EDGE 2020</a>
    
    </dd>
    
    <dt>20 Nov</dt>
    <dd>
    
    <a title="ARN WIICTA 2020" href="https://www.arnnet.com.au/wiicta/">ARN WIICTA 2020</a>
    
    </dd>
    
    
    

    
    
    
    <h2>Industry Events</h2>
    
    <dt>27 May</dt>
    <dd><a title="World Business Forum Sydney" href="/event/4400/world-business-forum-sydney">World Business Forum Sydney</a></dd>
    
    <dt>24 Jun</dt>
    <dd><a title="TECHSPO Sydney 2020" href="/event/4496/techspo-sydney-2020">TECHSPO Sydney 2020</a></dd>
    
    <dt>24 Jun</dt>
    <dd><a title="DigiMarCon Australia 2020 - Digital Marketing Conference &amp; Exhibition" href="/event/4492/digimarcon-australia-2020-digital-marketing-conference-exhibition">DigiMarCon Australia 2020 - Digital Marketing Conference &amp; Exhibition</a></dd>
    
    

    <dd><a class="more" href="/events/upcoming/">View all events</a></dd>
    
  </dl>

  <div class="hotevents" data-load="sub_events_hotevents">
    
    



  <h2>Featured</h2>
  <ul class="lo-event_promos">
  
    <li>
      <article class="lo-event_promo">
        <a class="lo-event_promo_image" href="https://www.arnnet.com.au/emerging_leaders/">
          <img class="lazyload" src="https://www.idgcdn.com.au/compressor-staticfiles/lazysizes/placehold.png?release=20200406163827" data-src="https://d2bs8hqp6qvsw6.cloudfront.net/promoted-content/image/250x100/promoted_content/promo/icon_29.png" alt="Emerging Leaders 2020">
          <p class="lo-event_promo_summary">Emerging Leaders 2020</p>
        </a>
        <h3 class="lo-event_promo_title"><a href="https://www.arnnet.com.au/emerging_leaders/">Emerging Leaders 2020</a></h3>
      </article>
    </li>
  
    <li>
      <article class="lo-event_promo">
        <a class="lo-event_promo_image" href="http://www.arnnet.com.au/edge/">
          <img class="lazyload" src="https://www.idgcdn.com.au/compressor-staticfiles/lazysizes/placehold.png?release=20200406163827" data-src="https://d2bs8hqp6qvsw6.cloudfront.net/promoted-content/image/250x100/promoted_content/promo/icon_22.jpg" alt="EDGE 2020">
          <p class="lo-event_promo_summary">EDGE 2020</p>
        </a>
        <h3 class="lo-event_promo_title"><a href="http://www.arnnet.com.au/edge/">EDGE 2020</a></h3>
      </article>
    </li>
  
    <li>
      <article class="lo-event_promo">
        <a class="lo-event_promo_image" href="https://www.arnnet.com.au/innovation_awards/">
          <img class="lazyload" src="https://www.idgcdn.com.au/compressor-staticfiles/lazysizes/placehold.png?release=20200406163827" data-src="https://d2bs8hqp6qvsw6.cloudfront.net/promoted-content/image/250x100/promoted_content/promo/icon_31.png" alt="ARN Innovation Awards">
          <p class="lo-event_promo_summary">ARN Innovation Awards</p>
        </a>
        <h3 class="lo-event_promo_title"><a href="https://www.arnnet.com.au/innovation_awards/">ARN Innovation Awards</a></h3>
      </article>
    </li>
  
    <li>
      <article class="lo-event_promo">
        <a class="lo-event_promo_image" href="http://www.arnnet.com.au/wiicta/">
          <img class="lazyload" src="https://www.idgcdn.com.au/compressor-staticfiles/lazysizes/placehold.png?release=20200406163827" data-src="https://d2bs8hqp6qvsw6.cloudfront.net/promoted-content/image/250x100/promoted_content/promo/icon_32.png" alt="Women in ICT Awards">
          <p class="lo-event_promo_summary">Women in ICT Awards</p>
        </a>
        <h3 class="lo-event_promo_title"><a href="http://www.arnnet.com.au/wiicta/">Women in ICT Awards</a></h3>
      </article>
    </li>
  
  </ul>


    
  </div>
</div>

<script>
  $('#load_dropcontent [data-load]').each(function() { $("[data-placeholder="+$(this).data('load')+"]").replaceWith(this); });
</script>

<script src="https://jobs.arnnet.com.au/js/widget.js" data-origin="https://jobs.arnnet.com.au" data-widget-title="Latest Jobs" data-limit ="3" type="text/javascript"></script>


<script type="text/javascript">
var disqus_shortname = 'arnnet';

/*
(function () {
var s = document.createElement('script'); s.async = true;
s.type = 'text/javascript';
s.src = 'http://' + disqus_shortname + '.disqus.com/count.js';
(document.getElementsByTagName('HEAD')[0] || document.getElementsByTagName('BODY')[0]).appendChild(s);
}());
*/

// This lets us know when the JS has loaded and after the counts are fetched.
function disqus_counts_loaded() {
	DISQUSWIDGETS.old_displayCount = DISQUSWIDGETS.displayCount;

	// Override the old displayCount() with a new one so we can attach our helper onto it.
	DISQUSWIDGETS.displayCount = function(arg) {
		DISQUSWIDGETS.old_displayCount(arg);
		$("a[href$=#disqus_thread],*[data-disqus-identifier]").trigger('disqus-counts-loaded');
	}
}

$.getScript('//' + disqus_shortname + '.disqus.com/count.js', disqus_counts_loaded);
</script>




<!-- Crazy Egg Tracking -->
<script type="text/javascript">
setTimeout(function(){var a=document.createElement("script");
var b=document.getElementsByTagName("script")[0];
a.src=document.location.protocol+"//script.crazyegg.com/pages/scripts/0018/8767.js?"+Math.floor(new Date().getTime()/3600000);
a.async=true;a.type="text/javascript";b.parentNode.insertBefore(a,b)}, 1);
</script>



<!-- Twitter universal website tag code -->
<script>
!function(e,n,u,a){e.twq||(a=e.twq=function(){a.exe?a.exe.apply(a,arguments):
a.queue.push(arguments);},a.version='1',a.queue=[],t=n.createElement(u),
t.async=!0,t.src='//static.ads-twitter.com/uwt.js',s=n.getElementsByTagName(u)[0],
s.parentNode.insertBefore(t,s))}(window,document,'script');
// Insert Twitter Pixel ID and Standard Event data below
twq('init','nv5jw');
twq('track','PageView');
</script>
<!-- End Twitter universal website tag code -->

<!-- Taboola Pixel Code -->
<script type='text/javascript'>
  window._tfa = window._tfa || [];
  window._tfa.push({notify: 'event', name: 'page_view', id: 1009432});
  !function (t, f, a, x) {
         if (!document.getElementById(x)) {
            t.async = 1;t.src = a;t.id=x;f.parentNode.insertBefore(t, f);
         }
  }(document.createElement('script'),
  document.getElementsByTagName('script')[0],
  '//cdn.taboola.com/libtrc/unip/1009432/tfa.js',
  'tb_tfa_script');
</script>
<noscript>
  <img src='//trc.taboola.com/1009432/log/3/unip?en=page_view'
      width='0' height='0' style='display:none'/>
</noscript>
<!-- End of Taboola Pixel Code -->


<script type="text/javascript"> _linkedin_data_partner_id = "186603"; </script>
<script type="text/javascript"> 
    (function(){
        var s = document.getElementsByTagName("script")[0]; 
        var b = document.createElement("script"); 
        b.type = "text/javascript";
        b.async = true; 
        b.src = "https://snap.licdn.com/li.lms-analytics/insight.min.js"; 
        s.parentNode.insertBefore(b, s);
    })(); 
</script> 
<noscript>
    <img height="1" width="1" style="display:none;" alt="" src="https://dc.ads.linkedin.com/collect/?pid=186603&fmt=gif" />
</noscript>




<script type="text/javascript">
  var clarity_tracking_starter = function (override_context_data) {
    var d=document;
    var id = 'idg-tracking';
    var s='script';
    var js, fjs = d.getElementsByTagName(s)[0];

    if (d.getElementById(id)) {
      runClarity();
      return false
    }
    
    js = d.createElement(s); 
    js.id = id; 
    js.type = "text/javascript";
    js.onload = function () {runClarity()};
    js.src = "https://www.idgcdn.com.au/compressor-staticfiles/clarity/idg_clarity.js?release=20200406163827";
    fjs.parentNode.insertBefore(js, fjs);

    function runClarity(){
      var dynamic_key_val_api = "/script-tagger/clarity/json/";
      var first_page_context_data = {
        'event_type':"pageview",'tags':["copyright", "Oracle", "Google", "API"],'author':"Peter Wayner",'word_count':1928,'publication_datetime':"2020-03-23T17:00:00+00:00",'score':1,'content_type':"article",'content_id':328583900
      }

      // Context data can be overridden and is used on infinite scroll pages to pass in 
      // context of the new article that is loaded on the page.
      var context_data = override_context_data || first_page_context_data;

      clarity_logger.init(
        dynamic_key_val_api,
        'https://clarity-api-prod.idg.com.au/collect/client', 
        context_data
      );
    }
  };
</script> 



</div><!-- lo-script -->
</body></html>
