Menu
Cisco security updates fail on select routers

Cisco security updates fail on select routers

Patches issued in January were found to be "incomplete"

Credit: Dreamstime

Cisco customers using Small Business RV320 and RV325 who updated the online management interface for the dual gigabit WAN VPN routers in January will need to update it again.

The vendor has published 25 security alerts including for the two routers management interface as it found the patches issued in January were incomplete.

In its security advisories page, Cisco said that it still does not have a fix but it is working on it.

The vulnerability allowed an "unauthenticated, remote attacker to retrieve sensitive information" and it is due to access controls for URLs.

"An attacker could exploit this vulnerability by connecting to an affected device via HTTP or HTTPS and requesting specific URLs," it explained. "A successful exploit could allow the attacker to download the router configuration or detailed diagnostic information."

The networking giant also said that there are no current firmware updates that address the issue or any workarounds. A fix to this vulnerability is expected to be available by mid-April.

The same applies for the routers' command injection vulnerability, also first advised in January. This vulnerability could allow an authenticated, remote attacker with administrative privileges on an affected device to execute arbitrary commands.

The attacker could exploit this vulnerability by sending malicious HTTP POST requests to the web-based management interface of an affected device.

"A successful exploit could allow the attacker to execute arbitrary commands on the underlying Linux shell as root."

The other 23 updates include 17 of high impact and the remaining of medium impact, all can be found here.


Follow Us

Join the newsletter!

Or

Sign up to gain exclusive access to email subscriptions, event invitations, competitions, giveaways, and much more.

Membership is free, and your security and privacy remain protected. View our privacy policy before signing up.

Error: Please check your email address.

Tags ciscoroutersvulnerability

Show Comments